Sandbox
Incident Report for Intuit Developer Group
Resolved
Issues with Sandbox have been resolved
Posted about 1 month ago. Mar 16, 2017 - 17:55 PDT
Investigating
Sandbox is currently experiencing intermittent issues (Incident ID:INC0507044).
Posted about 1 month ago. Mar 16, 2017 - 15:07 PDT
This incident affected: QuickBooks Sandbox.