QuickBooks Apps.com product reviews are not showing on the site
Incident Report for Intuit Developer Group
Resolved
Product reviews are now showing on apps.com
Posted Aug 18, 2016 - 10:58 PDT
Investigating
We are aware of an issue where reviews, and the current star ratings for applications are not showing on QuickBooks Apps.com. Intuit operations is looking into the issue.
Posted Aug 18, 2016 - 08:26 PDT
This incident affected: QuickBooks Apps.com.