Payments API
Incident Report for Intuit Developer Group
Resolved
This incident has been resolved.
Posted 3 months ago. May 16, 2019 - 08:02 PDT
Investigating
Payments API is currently experiencing intermittent issues (Incident ID: INC0884602).
Posted 3 months ago. May 15, 2019 - 14:08 PDT
This incident affected: QuickBooks Payments API.