Intuit Developer Portal is experiencing intermittent issues (Incident ID: INC1020474)
Incident Report for Intuit Developer Group
Resolved
Third-party developers were unable to perform testing of QBO sandbox company creation and payment account signups on Intuit Developer Portal.

This incident is now Resolved.
Posted Feb 26, 2020 - 20:56 PST
Investigating
We are currently investigating this issue.
Posted Feb 26, 2020 - 20:38 PST
This incident affected: Intuit Developer Portal and QuickBooks Sandbox.