Payments API
Incident Report for Intuit Developer Group
Resolved
This incident has been resolved.
Posted 12 days ago. Jun 04, 2019 - 02:50 PDT
Investigating
Payments API is currently experiencing intermittent issues (Incident ID: INC0891817).
Posted 12 days ago. Jun 04, 2019 - 02:48 PDT
This incident affected: QuickBooks Payments API.