Ongoing issue with the App Store review page preventing customers from leaving reviews for third-party apps.

Incident Report for Intuit Developer Group

Resolved

The incident was resolved on 09/19/25 at 7:50 PM PST.
Posted Sep 22, 2025 - 11:00 PDT

Investigating

We are currently investigating this issue.
Posted Sep 19, 2025 - 09:08 PDT
This incident affected: QuickBooks Apps.com.