Ongoing issue with showing certain tabs (Webhooks, Analytics, redirect URL) & sandboxes under My Hub on developer portal

Incident Report for Intuit Developer Group

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 13:55 PDT

Investigating

We are currently investigating this issue.
Posted Oct 03, 2025 - 00:30 PDT
This incident affected: Intuit Developer Portal.