Intermittent timeout errors when accessing the QuickBooks Balance Sheet API.

Incident Report for Intuit Developer Group

Update

A subset of QuickBooks customers may experience intermittent timeout errors when accessing BalanceSheet API.
Posted Apr 29, 2026 - 14:12 PDT

Investigating

We are currently investigating this issue.
Posted Apr 29, 2026 - 09:00 PDT
This incident affects: QuickBooks Online API.