Apps.com is facing intermittent issues
Incident Report for Intuit Developer Group
Resolved
This incident has been resolved.
Posted 9 months ago. Dec 16, 2018 - 20:11 PST
Update
We are continuing to investigate this issue.
Posted 9 months ago. Dec 12, 2018 - 13:10 PST
Investigating
Customers are having issues in posting reviews and submitting comments on reviews on Apps.com
Posted 9 months ago. Dec 12, 2018 - 13:10 PST
This incident affected: QuickBooks Apps.com.