Intuit Developer Portal is experiencing intermittent issues [Incident Id: INC0982342]
Incident Report for Intuit Developer Group
Resolved
This incident has been resolved.
Posted Jan 09, 2020 - 05:33 PST
Investigating
Intuit Developer Portal is experiencing issues when trying to open the portal within Internet Explorer.

As a workaround, you can use a different browser to access the site.

Our engineers are working on resolving this issue as quickly as possible.
Posted Jan 08, 2020 - 07:11 PST
This incident affected: Intuit Developer Portal.