Some Customers are having issues in posting reviews and submitting comments on reviews on Apps.com
Incident Report for Intuit Developer Group
Resolved
This incident has been resolved.
Posted about 2 months ago. Dec 18, 2018 - 14:24 PST
Update
We are continuing to investigate this issue.
Posted 2 months ago. Dec 17, 2018 - 23:29 PST
Investigating
We are currently investigating this issue.
Posted 2 months ago. Dec 17, 2018 - 23:29 PST
This incident affected: QuickBooks Apps.com.