Major outage resulting in intermittent API timeout errors, sandbox company loading issues, and OAuth connection failures.

Incident Report for Intuit Developer Group

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 20:45 PDT

Update

We are continuing to investigate this issue.
Posted Sep 01, 2026 - 17:15 PDT

Update

Investigating — We are currently seeing a widespread issue affecting sandbox company loading in the Developer Portal, app connection (OAuth) failures, and QuickBooks Online API timeout errors.
Posted Sep 01, 2026 - 16:22 PDT

Update

We are continuing to investigate this issue.
Posted Sep 01, 2026 - 16:00 PDT

Update

Update — We're still engaged with the team on this.
Posted Sep 01, 2026 - 14:23 PDT

Update

Investigating — We're engaged with the team to investigate and assess the impact. This appears to be on Intuit's side, not your integration.
Posted Sep 01, 2026 - 13:57 PDT

Update

The QuickBooks Online APIs are returning intermittent 503 timeout errors due to an internal incident.
Posted Sep 01, 2026 - 13:53 PDT

Investigating

We are currently investigating this issue.
Posted Sep 01, 2026 - 13:00 PDT
This incident affected: Intuit Developer Portal, QuickBooks Online API, QuickBooks Sandbox, and OAuth APIs.